Getting Started

Dependencies

Java Version

linkki requires Java 17 or later.

Libraries

linkki-core depends on the following external libraries:

groupId artifactId version

com.github.spotbugs

spotbugs-annotations

4.7.3

org.apache.commons

commons-lang3

3.12.0

linkki-core-vaadin-flow depends on the following Vaadin Flow modules:

groupId artifactId version

com.vaadin

vaadin-core

24.1.16

Optional Libraries

linkki can be used with Spring Boot, this version is tested with Spring Boot version 3.1.7 .